$re = '/(?<![A-Za-z0-9])[A-G][b#]?(?=(?:m(?:(?:aj|in)(?:or)?)?)?(?![A-Za-z]))/mi';
$str = 'sample_F_one_shot.wav
sample_oneshot_F#maj.wav
sample_Ab_one_shot.wav
[F]
(A#)
F#maj
C1
F#2
Gm
Diginoiz_-MVP4_OneShot_G#Maj-_Bass
FROM THIS LINE
VEDH Synth Cut 028 GMaj7-9.wav
VEDH Synth Cut 046 FMaj7.wav';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);