use strict;
my $str = 'sample_F_one_shot.wav
sample_oneshot_F#maj.wav
sample_Ab_one_shot.wav
[F]
(A#)
F#maj
C1
F#2
Gm
Diginoiz_-MVP4_OneShot_G#Maj-_Bass
FROM THIS LINE
VEDH Synth Cut 028 GMaj7-9.wav
VEDH Synth Cut 046 FMaj7.wav';
my $regex = qr/(?<![A-Za-z0-9])[A-G][b#]?(?=(?:m(?:(?:aj|in)(?:or)?)?)?(?![A-Za-z]))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}