const regex = /(?<![A-Za-z0-9])[A-G][b#]?(?=(?:m(?:(?:aj|in)(?:or)?)?)?(?![A-Za-z]))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![A-Za-z0-9])[A-G][b#]?(?=(?:m(?:(?:aj|in)(?:or)?)?)?(?![A-Za-z]))', 'gmi')
const str = `sample_F_one_shot.wav
sample_oneshot_F#maj.wav
sample_Ab_one_shot.wav
[F]
(A#)
F#maj
C1
F#2
Gm
Diginoiz_-MVP4_OneShot_G#Maj-_Bass
FROM THIS LINE
VEDH Synth Cut 028 GMaj7-9.wav
VEDH Synth Cut 046 FMaj7.wav`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}