import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^>]*>?|[^<]*>";
final String string = "issing either < or > if<> they occur at the start or end of the string, respectively. For example<yyiuyi, \n"
+ "body> text< \n\n"
+ "iuyoi> uyoiyo </bodyjhkj \n\n\n"
+ "<script>\n"
+ "<script />\n"
+ "<script></script>\n"
+ "<script adsas></script>\n"
+ "<script adsasd />\n"
+ "< script>\n"
+ "<scriptscriptscript><%adsU&#script>\n"
+ "sa a<script>a<script>\n"
+ "<SCRiPT>\n"
+ "<script sd dsaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa> </script>\n"
+ "<scriiuoiuoipt>alert(\\'a\\')</s\n"
+ "cript\n"
+ ">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}