re = /<[^>]*>?|[^<]*>/m
str = 'issing either < or > if<> they occur at the start or end of the string, respectively. For example<yyiuyi,
body> text<
iuyoi> uyoiyo </bodyjhkj
<script>
<script />
<script></script>
<script adsas></script>
<script adsasd />
< script>
<scriptscriptscript><%adsU&#script>
sa a<script>a<script>
<SCRiPT>
<script sd dsaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa> </script>
<scriiuoiuoipt>alert(\\\'a\\\')</s
cript
>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end