const regex = /<[^>]*>?|[^<]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]*>?|[^<]*>', 'gm')
const str = `issing either < or > if<> they occur at the start or end of the string, respectively. For example<yyiuyi,
body> text<
iuyoi> uyoiyo </bodyjhkj
<script>
<script />
<script></script>
<script adsas></script>
<script adsasd />
< script>
<scriptscriptscript><%adsU&#script>
sa a<script>a<script>
<SCRiPT>
<script sd dsaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa> </script>
<scriiuoiuoipt>alert(\\'a\\')</s
cript
>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}