use strict;
my $str = 'issing either < or > if<> they occur at the start or end of the string, respectively. For example<yyiuyi,
body> text<
iuyoi> uyoiyo </bodyjhkj
<script>
<script />
<script></script>
<script adsas></script>
<script adsasd />
< script>
<scriptscriptscript><%adsU&#script>
sa a<script>a<script>
<SCRiPT>
<script sd dsaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa> </script>
<scriiuoiuoipt>alert(\\\'a\\\')</s
cript
>';
my $regex = qr/<[^>]*>?|[^<]*>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}