package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<date>\d{4}-\d{1,2}-\d{1,2})T(?<time>\d{1,2}:\d{1,2}:\d{1,2})\+\d{1,2}:\d{1,2}\s(?<level>\w+\s\(\d\)):\s(?<msg>.*$)`)
var str = `2015-10-23T14:48:03+00:00 INFO (6): NewProducts:: Observed customer login event
2015-10-23T14:48:03+00:00 DEBUG (7): NewProducts:: Customer is not checking out
2015-10-23T14:48:11+00:00 NOTICE (5): Freee
2015-10-23T14:48:24+00:00 NOTICE (5): Freee
2015-10-23T14:48:48+00:00 NOTICE (5): Freee
2015-10-23T14:48:58+00:00 NOTICE (5): Freee
2015-10-23T14:49:02+00:00 NOTICE (5): Freee
2015-10-23T14:49:02+00:00 NOTICE (5): Freee
2015-10-23T14:49:04+00:00 DEBUG (7): New Order being placed!
2015-10-23T14:49:04+00:00 DEBUG (7): This order has been preapproved
2015-10-23T14:49:04+00:00 DEBUG (7): Setting order state/status to approved/approved
2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event
2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event
2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can edit
2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot edit
2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can cancel
2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot cancel
2015-10-23T14:49:07+00:00 DEBUG (7): getting order flag
2015-10-23T14:49:07+00:00 DEBUG (7):
2015-10-23T14:49:07+00:00 ERR (3): Array
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}