import re
regex = re.compile(r"(?<date>\d{4}-\d{1,2}-\d{1,2})T(?<time>\d{1,2}:\d{1,2}:\d{1,2})\+\d{1,2}:\d{1,2}\s(?<level>\w+\s\(\d\)):\s(?<msg>.*$)", flags=re.MULTILINE)
test_str = ("2015-10-23T14:48:03+00:00 INFO (6): NewProducts:: Observed customer login event\n"
"2015-10-23T14:48:03+00:00 DEBUG (7): NewProducts:: Customer is not checking out\n"
"2015-10-23T14:48:11+00:00 NOTICE (5): Freee\n"
"2015-10-23T14:48:24+00:00 NOTICE (5): Freee\n"
"2015-10-23T14:48:48+00:00 NOTICE (5): Freee\n"
"2015-10-23T14:48:58+00:00 NOTICE (5): Freee\n"
"2015-10-23T14:49:02+00:00 NOTICE (5): Freee\n"
"2015-10-23T14:49:02+00:00 NOTICE (5): Freee\n"
"2015-10-23T14:49:04+00:00 DEBUG (7): New Order being placed!\n"
"2015-10-23T14:49:04+00:00 DEBUG (7): This order has been preapproved\n"
"2015-10-23T14:49:04+00:00 DEBUG (7): Setting order state/status to approved/approved\n"
"2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event\n"
"2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event\n"
"2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can edit\n"
"2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot edit\n"
"2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can cancel\n"
"2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot cancel\n"
"2015-10-23T14:49:07+00:00 DEBUG (7): getting order flag\n"
"2015-10-23T14:49:07+00:00 DEBUG (7): \n"
"2015-10-23T14:49:07+00:00 ERR (3): Array\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")