import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<date>\\d{4}-\\d{1,2}-\\d{1,2})T(?<time>\\d{1,2}:\\d{1,2}:\\d{1,2})\\+\\d{1,2}:\\d{1,2}\\s(?<level>\\w+\\s\\(\\d\\)):\\s(?<msg>.*$)";
final String string = "2015-10-23T14:48:03+00:00 INFO (6): NewProducts:: Observed customer login event\n"
+ "2015-10-23T14:48:03+00:00 DEBUG (7): NewProducts:: Customer is not checking out\n"
+ "2015-10-23T14:48:11+00:00 NOTICE (5): Freee\n"
+ "2015-10-23T14:48:24+00:00 NOTICE (5): Freee\n"
+ "2015-10-23T14:48:48+00:00 NOTICE (5): Freee\n"
+ "2015-10-23T14:48:58+00:00 NOTICE (5): Freee\n"
+ "2015-10-23T14:49:02+00:00 NOTICE (5): Freee\n"
+ "2015-10-23T14:49:02+00:00 NOTICE (5): Freee\n"
+ "2015-10-23T14:49:04+00:00 DEBUG (7): New Order being placed!\n"
+ "2015-10-23T14:49:04+00:00 DEBUG (7): This order has been preapproved\n"
+ "2015-10-23T14:49:04+00:00 DEBUG (7): Setting order state/status to approved/approved\n"
+ "2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event\n"
+ "2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event\n"
+ "2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can edit\n"
+ "2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot edit\n"
+ "2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can cancel\n"
+ "2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot cancel\n"
+ "2015-10-23T14:49:07+00:00 DEBUG (7): getting order flag\n"
+ "2015-10-23T14:49:07+00:00 DEBUG (7): \n"
+ "2015-10-23T14:49:07+00:00 ERR (3): Array\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}