const regex = /(?<date>\d{4}-\d{1,2}-\d{1,2})T(?<time>\d{1,2}:\d{1,2}:\d{1,2})\+\d{1,2}:\d{1,2}\s(?<level>\w+\s\(\d\)):\s(?<msg>.*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<date>\\d{4}-\\d{1,2}-\\d{1,2})T(?<time>\\d{1,2}:\\d{1,2}:\\d{1,2})\\+\\d{1,2}:\\d{1,2}\\s(?<level>\\w+\\s\\(\\d\\)):\\s(?<msg>.*$)', 'gm')
const str = `2015-10-23T14:48:03+00:00 INFO (6): NewProducts:: Observed customer login event
2015-10-23T14:48:03+00:00 DEBUG (7): NewProducts:: Customer is not checking out
2015-10-23T14:48:11+00:00 NOTICE (5): Freee
2015-10-23T14:48:24+00:00 NOTICE (5): Freee
2015-10-23T14:48:48+00:00 NOTICE (5): Freee
2015-10-23T14:48:58+00:00 NOTICE (5): Freee
2015-10-23T14:49:02+00:00 NOTICE (5): Freee
2015-10-23T14:49:02+00:00 NOTICE (5): Freee
2015-10-23T14:49:04+00:00 DEBUG (7): New Order being placed!
2015-10-23T14:49:04+00:00 DEBUG (7): This order has been preapproved
2015-10-23T14:49:04+00:00 DEBUG (7): Setting order state/status to approved/approved
2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event
2015-10-23T14:49:04+00:00 DEBUG (7): Captured Order Status Change Event
2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can edit
2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot edit
2015-10-23T14:49:06+00:00 DEBUG (7): parent says we can cancel
2015-10-23T14:49:06+00:00 WARN (4): we cannot approve, so we cannot cancel
2015-10-23T14:49:07+00:00 DEBUG (7): getting order flag
2015-10-23T14:49:07+00:00 DEBUG (7):
2015-10-23T14:49:07+00:00 ERR (3): Array
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}