package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:(?P<days>[0-9]{0,2})\s*day[^, ]*,? *)?(?:(?P<hrs>[0-9]+)\s*hour[^, ]*,? *)?(?:(?P<min>[0-9]+)\s*minute[^, ]*,? *)?`)
var str = `27 days, 21 hours, 23 minutes ago
21 hours, 23 minutes ago`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}