import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?P<days>[0-9]{0,2})\\s*day[^, ]*,? *)?(?:(?P<hrs>[0-9]+)\\s*hour[^, ]*,? *)?(?:(?P<min>[0-9]+)\\s*minute[^, ]*,? *)?";
final String string = "27 days, 21 hours, 23 minutes ago\n"
+ "21 hours, 23 minutes ago";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}