const regex = new RegExp('(?:(?P<days>[0-9]{0,2})\\s*day[^, ]*,? *)?(?:(?P<hrs>[0-9]+)\\s*hour[^, ]*,? *)?(?:(?P<min>[0-9]+)\\s*minute[^, ]*,? *)?', 'g')
const str = `27 days, 21 hours, 23 minutes ago
21 hours, 23 minutes ago`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}