re = /(?:(?P<days>[0-9]{0,2})\s*day[^, ]*,? *)?(?:(?P<hrs>[0-9]+)\s*hour[^, ]*,? *)?(?:(?P<min>[0-9]+)\s*minute[^, ]*,? *)?/
str = '27 days, 21 hours, 23 minutes ago
21 hours, 23 minutes ago'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end