#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\G(?!\A)|start\b)(?:(?!\bend\b).)*\K\R"
Local $sString = "start 1" & @CRLF & _
"2-" & @CRLF & _
"G" & @CRLF & _
"23" & @CRLF & _
"end" & @CRLF & _
"other" & @CRLF & _
"stuff"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")