$re = '/(?:\G(?!\A)|start\b)(?:(?!\bend\b).)*\K\R/';
$str = 'start 1
2-
G
23
end
other
stuff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);