import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|start\\b)(?:(?!\\bend\\b).)*\\K\\R";
final String string = "start 1\n"
+ "2-\n"
+ "G\n"
+ "23\n"
+ "end\n"
+ "other\n"
+ "stuff";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}