re = /(?:\G(?!\A)|start\b)(?:(?!\bend\b).)*\K\R/
str = 'start 1
2-
G
23
end
other
stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end