#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0(?:2(?:12|3[45789]|[45][1-9]|6[0-9]|7[0-8]|8[1235678]|9[1-5])|4(?:1[246]|2[46]))\d{7}$"
Local $sString = "02481234567" & @CRLF & _
"02811234567" & @CRLF & _
"02821234567" & @CRLF & _
"02831234567" & @CRLF & _
"02351234567" & @CRLF & _
"02471234567" & @CRLF & _
"02781234567" & @CRLF & _
"02431234567" & @CRLF & _
"02441234567" & @CRLF & _
"02451234567" & @CRLF & _
"02461234567" & @CRLF & _
"02731234567" & @CRLF & _
"02781234567" & @CRLF & _
"02351234567" & @CRLF & _
"02851234567" & @CRLF & _
"02861234567" & @CRLF & _
"02881234567" & @CRLF & _
"02411234567" & @CRLF & _
"02421234567" & @CRLF & _
"02431234567" & @CRLF & _
"02451234567" & @CRLF & _
"02491234567" & @CRLF & _
"02581234567" & @CRLF & _
"02871234567" & @CRLF & _
"02121234567" & @CRLF & _
"02591234567" & @CRLF & _
"02681234567" & @CRLF & _
"02691234567" & @CRLF & _
"02371234567" & @CRLF & _
"02351234567" & @CRLF & _
"02381234567" & @CRLF & _
"02461234567" & @CRLF & _
"02471234567" & @CRLF & _
"02511234567" & @CRLF & _
"02521234567" & @CRLF & _
"02531234567" & @CRLF & _
"02711234567" & @CRLF & _
"02731234567" & @CRLF & _
"02741234567" & @CRLF & _
"02751234567" & @CRLF & _
"02121234567" & @CRLF & _
"02341234567" & @CRLF & _
"02391234567" & @CRLF & _
"02871234567" & @CRLF & _
"02911234567" & @CRLF & _
"02921234567" & @CRLF & _
"02951234567" & @CRLF & _
"02551234567" & @CRLF & _
"02561234567" & @CRLF & _
"02571234567" & @CRLF & _
"02931234567" & @CRLF & _
"02941234567" & @CRLF & _
"02761234567" & @CRLF & _
"02771234567" & @CRLF & _
"02711234567" & @CRLF & _
"02721234567" & @CRLF & _
"02121234567" & @CRLF & _
"02511234567" & @CRLF & _
"02531234567" & @CRLF & _
"02541234567" & @CRLF & _
"02611234567" & @CRLF & _
"02621234567" & @CRLF & _
"02631234567" & @CRLF & _
"02641234567" & @CRLF & _
"02651234567" & @CRLF & _
"02661234567" & @CRLF & _
"02671234567" & @CRLF & _
"02711234567" & @CRLF & _
"02751234567" & @CRLF & _
"02601234567" & @CRLF & _
"02701234567" & @CRLF & _
"04121234567" & @CRLF & _
"04141234567" & @CRLF & _
"04241234567" & @CRLF & _
"04161234567" & @CRLF & _
"04261234567" & @CRLF & _
"04271234567" & @CRLF & _
"02131234567"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")