use strict;
my $str = '02481234567
02811234567
02821234567
02831234567
02351234567
02471234567
02781234567
02431234567
02441234567
02451234567
02461234567
02731234567
02781234567
02351234567
02851234567
02861234567
02881234567
02411234567
02421234567
02431234567
02451234567
02491234567
02581234567
02871234567
02121234567
02591234567
02681234567
02691234567
02371234567
02351234567
02381234567
02461234567
02471234567
02511234567
02521234567
02531234567
02711234567
02731234567
02741234567
02751234567
02121234567
02341234567
02391234567
02871234567
02911234567
02921234567
02951234567
02551234567
02561234567
02571234567
02931234567
02941234567
02761234567
02771234567
02711234567
02721234567
02121234567
02511234567
02531234567
02541234567
02611234567
02621234567
02631234567
02641234567
02651234567
02661234567
02671234567
02711234567
02751234567
02601234567
02701234567
04121234567
04141234567
04241234567
04161234567
04261234567
04271234567
02131234567';
my $regex = qr/^0(?:2(?:12|3[45789]|[45][1-9]|6[0-9]|7[0-8]|8[1235678]|9[1-5])|4(?:1[246]|2[46]))\d{7}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}