import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0(?:2(?:12|3[45789]|[45][1-9]|6[0-9]|7[0-8]|8[1235678]|9[1-5])|4(?:1[246]|2[46]))\\d{7}$";
final String string = "02481234567\n"
+ "02811234567\n"
+ "02821234567\n"
+ "02831234567\n"
+ "02351234567\n"
+ "02471234567\n"
+ "02781234567\n"
+ "02431234567\n"
+ "02441234567\n"
+ "02451234567\n"
+ "02461234567\n"
+ "02731234567\n"
+ "02781234567\n"
+ "02351234567\n"
+ "02851234567\n"
+ "02861234567\n"
+ "02881234567\n"
+ "02411234567\n"
+ "02421234567\n"
+ "02431234567\n"
+ "02451234567\n"
+ "02491234567\n"
+ "02581234567\n"
+ "02871234567\n"
+ "02121234567\n"
+ "02591234567\n"
+ "02681234567\n"
+ "02691234567\n"
+ "02371234567\n"
+ "02351234567\n"
+ "02381234567\n"
+ "02461234567\n"
+ "02471234567\n"
+ "02511234567\n"
+ "02521234567\n"
+ "02531234567\n"
+ "02711234567\n"
+ "02731234567\n"
+ "02741234567\n"
+ "02751234567\n"
+ "02121234567\n"
+ "02341234567\n"
+ "02391234567\n"
+ "02871234567\n"
+ "02911234567\n"
+ "02921234567\n"
+ "02951234567\n"
+ "02551234567\n"
+ "02561234567\n"
+ "02571234567\n"
+ "02931234567\n"
+ "02941234567\n"
+ "02761234567\n"
+ "02771234567\n"
+ "02711234567\n"
+ "02721234567\n"
+ "02121234567\n"
+ "02511234567\n"
+ "02531234567\n"
+ "02541234567\n"
+ "02611234567\n"
+ "02621234567\n"
+ "02631234567\n"
+ "02641234567\n"
+ "02651234567\n"
+ "02661234567\n"
+ "02671234567\n"
+ "02711234567\n"
+ "02751234567\n"
+ "02601234567\n"
+ "02701234567\n"
+ "04121234567\n"
+ "04141234567\n"
+ "04241234567\n"
+ "04161234567\n"
+ "04261234567\n"
+ "04271234567\n"
+ "02131234567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}