# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^0(?:2(?:12|3[45789]|[45][1-9]|6[0-9]|7[0-8]|8[1235678]|9[1-5])|4(?:1[246]|2[46]))\d{7}$"
test_str = ("02481234567\n"
"02811234567\n"
"02821234567\n"
"02831234567\n"
"02351234567\n"
"02471234567\n"
"02781234567\n"
"02431234567\n"
"02441234567\n"
"02451234567\n"
"02461234567\n"
"02731234567\n"
"02781234567\n"
"02351234567\n"
"02851234567\n"
"02861234567\n"
"02881234567\n"
"02411234567\n"
"02421234567\n"
"02431234567\n"
"02451234567\n"
"02491234567\n"
"02581234567\n"
"02871234567\n"
"02121234567\n"
"02591234567\n"
"02681234567\n"
"02691234567\n"
"02371234567\n"
"02351234567\n"
"02381234567\n"
"02461234567\n"
"02471234567\n"
"02511234567\n"
"02521234567\n"
"02531234567\n"
"02711234567\n"
"02731234567\n"
"02741234567\n"
"02751234567\n"
"02121234567\n"
"02341234567\n"
"02391234567\n"
"02871234567\n"
"02911234567\n"
"02921234567\n"
"02951234567\n"
"02551234567\n"
"02561234567\n"
"02571234567\n"
"02931234567\n"
"02941234567\n"
"02761234567\n"
"02771234567\n"
"02711234567\n"
"02721234567\n"
"02121234567\n"
"02511234567\n"
"02531234567\n"
"02541234567\n"
"02611234567\n"
"02621234567\n"
"02631234567\n"
"02641234567\n"
"02651234567\n"
"02661234567\n"
"02671234567\n"
"02711234567\n"
"02751234567\n"
"02601234567\n"
"02701234567\n"
"04121234567\n"
"04141234567\n"
"04241234567\n"
"04161234567\n"
"04261234567\n"
"04271234567\n"
"02131234567")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.