using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/message\/posts[^?]*$";
string input = @"/message/posts
/message/posts?a=b
/message/posts/lalala
/message/posts/lalala?n=v";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}