package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\/message\/posts[^?]*$`)
var str = `/message/posts
/message/posts?a=b
/message/posts/lalala
/message/posts/lalala?n=v`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}