$re = '/^\/message\/posts[^?]*$/m';
$str = '/message/posts
/message/posts?a=b
/message/posts/lalala
/message/posts/lalala?n=v';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);