re = /^\/message\/posts[^?]*$/m
str = '/message/posts
/message/posts?a=b
/message/posts/lalala
/message/posts/lalala?n=v'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end