import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "'\\s*(?0)?[^']*'\\K|(\\w+)";
final String string = "SELECT column_name FROM table_name WHERE column_name IN ('A' , 'st9u' ,'Meyer', ....);\n"
+ "WHERE a.object_type IN (' 'TABLE'', ''MATEerialIZED VIE3W' ')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}