$re = '/\'\s*(?0)?[^\']*\'\K|(\w+)/';
$str = 'SELECT column_name FROM table_name WHERE column_name IN (\'A\' , \'st9u\' ,\'Meyer\', ....);
WHERE a.object_type IN (\' \'TABLE\'\', \'\'MATEerialIZED VIE3W\' \')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);