use strict;
my $str = 'SELECT column_name FROM table_name WHERE column_name IN (\'A\' , \'st9u\' ,\'Meyer\', ....);
WHERE a.object_type IN (\' \'TABLE\'\', \'\'MATEerialIZED VIE3W\' \')';
my $regex = qr/'\s*(?0)?[^']*'\K|(\w+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}