using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d*(\.\d*)?([+\-*%]|$))*";
string input = @"1.1+3.3-1.5*33.33
4.4+3.3-3*444.5555%5.6
1.1
.5
1.
4444.44.44-333.33.33
333.33.3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}