$re = '/^(\d*(\.\d*)?([+\-*%]|$))*/m';
$str = '1.1+3.3-1.5*33.33
4.4+3.3-3*444.5555%5.6
1.1
.5
1.
4444.44.44-333.33.33
333.33.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);