package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d*(\.\d*)?([+\-*%]|$))*`)
var str = `1.1+3.3-1.5*33.33
4.4+3.3-3*444.5555%5.6
1.1
.5
1.
4444.44.44-333.33.33
333.33.3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}