use strict;
my $str = '1.1+3.3-1.5*33.33
4.4+3.3-3*444.5555%5.6
1.1
.5
1.
4444.44.44-333.33.33
333.33.3';
my $regex = qr/^(\d*(\.\d*)?([+\-*%]|$))*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}