#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\((?<fonction>(.*))\))?(?<vehicule>(.*))\s/\s(?<motif>(.*))/\s?(?<numero>\d+[A-Z]*)?\s?(?<voie>(.*)),\s(?<commune>(.*))"
Local $sString = "(TEST1)TEST2 / TEST3 / 1 RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1BIS RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1TER RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1 BIS RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1 TER RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1A RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1B RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1C RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1 A RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1 B RUE DU TEST, COMMUNE" & @CRLF & _
"(TEST1)TEST2 / TEST3 / 1 C RUE DU TEST, COMMUNE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")