import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\((?<fonction>(.*))\\))?(?<vehicule>(.*))\\s/\\s(?<motif>(.*))/\\s?(?<numero>\\d+[A-Z]*)?\\s?(?<voie>(.*)),\\s(?<commune>(.*))";
final String string = "(TEST1)TEST2 / TEST3 / 1 RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1BIS RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1TER RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1 BIS RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1 TER RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1A RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1B RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1C RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1 A RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1 B RUE DU TEST, COMMUNE\n"
+ "(TEST1)TEST2 / TEST3 / 1 C RUE DU TEST, COMMUNE";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}