$re = '~(\((?<fonction>(.*))\))?(?<vehicule>(.*))\s/\s(?<motif>(.*))/\s?(?<numero>\d+[A-Z]*)?\s?(?<voie>(.*)),\s(?<commune>(.*))~';
$str = '(TEST1)TEST2 / TEST3 / 1 RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1BIS RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1TER RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 BIS RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 TER RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1A RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1B RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1C RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 A RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 B RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 C RUE DU TEST, COMMUNE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);