import Foundation
let pattern = #"(\((?<fonction>(.*))\))?(?<vehicule>(.*))\s/\s(?<motif>(.*))/\s?(?<numero>\d+[A-Z]*)?\s?(?<voie>(.*)),\s(?<commune>(.*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(TEST1)TEST2 / TEST3 / 1 RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1BIS RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1TER RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 BIS RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 TER RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1A RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1B RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1C RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 A RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 B RUE DU TEST, COMMUNE
(TEST1)TEST2 / TEST3 / 1 C RUE DU TEST, COMMUNE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)