#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\\+?52[\\s\\-]?)"
Local $sString = "52 "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)