using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\+?52[\\s\\-]?)";
string substitution = @"";
string input = @"52 ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}