const regex = /(\\+?52[\\s\\-]?)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\+?52[\\\\s\\\\-]?)', '')
const str = `52 `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);