using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\|\d|])(?P<gidnumber>\d+)\|(?P<rang>\d+)\|(?P<fonction>[A-Z]+)";
string input = @"18909;11877;11872;5187|4|CHEF,789456;1237;11872;122|4|CHEF,18909;11877;11872;5187|4|CHEF";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}