import Foundation
let pattern = #"(?<![\|\d|])(?P<gidnumber>\d+)\|(?P<rang>\d+)\|(?P<fonction>[A-Z]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"18909;11877;11872;5187|4|CHEF,789456;1237;11872;122|4|CHEF,18909;11877;11872;5187|4|CHEF"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)