import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\|\\d|])(?P<gidnumber>\\d+)\\|(?P<rang>\\d+)\\|(?P<fonction>[A-Z]+)";
final String string = "18909;11877;11872;5187|4|CHEF,789456;1237;11872;122|4|CHEF,18909;11877;11872;5187|4|CHEF";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}