import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([4-9]{1,1}\\.([6-9]{1,1}\\.([9]{1,1}$|[0-9]{2,}$)|[0-9]{2,}\\.[0-9]{1,}$)|[0-9]{2,}\\.[0-9]{1,}\\.[0-9]{1,}$)";
final String string = "Target: 4.6.9\n"
+ "4.6.91\n"
+ "4.6.19\n"
+ "4.6.1\n"
+ "4.6.10\n\n"
+ "4.63.9\n"
+ "4.56.9\n"
+ "4.7.9\n"
+ "4.5.9\n"
+ "4.10.9\n"
+ "4.1.9\n"
+ "42.6.9\n"
+ "24.6.9\n"
+ "5.6.9\n"
+ "3.6.9\n"
+ "1.6.9\n"
+ "10.6.9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}