const regex = /([4-9]{1,1}\.([6-9]{1,1}\.([9]{1,1}$|[0-9]{2,}$)|[0-9]{2,}\.[0-9]{1,}$)|[0-9]{2,}\.[0-9]{1,}\.[0-9]{1,}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([4-9]{1,1}\\.([6-9]{1,1}\\.([9]{1,1}$|[0-9]{2,}$)|[0-9]{2,}\\.[0-9]{1,}$)|[0-9]{2,}\\.[0-9]{1,}\\.[0-9]{1,}$)', 'gm')
const str = `Target: 4.6.9
4.6.91
4.6.19
4.6.1
4.6.10
4.63.9
4.56.9
4.7.9
4.5.9
4.10.9
4.1.9
42.6.9
24.6.9
5.6.9
3.6.9
1.6.9
10.6.9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}