$re = '/([4-9]{1,1}\.([6-9]{1,1}\.([9]{1,1}$|[0-9]{2,}$)|[0-9]{2,}\.[0-9]{1,}$)|[0-9]{2,}\.[0-9]{1,}\.[0-9]{1,}$)/m';
$str = 'Target: 4.6.9
4.6.91
4.6.19
4.6.1
4.6.10
4.63.9
4.56.9
4.7.9
4.5.9
4.10.9
4.1.9
42.6.9
24.6.9
5.6.9
3.6.9
1.6.9
10.6.9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);