import re
regex = re.compile(r"([4-9]{1,1}\.([6-9]{1,1}\.([9]{1,1}$|[0-9]{2,}$)|[0-9]{2,}\.[0-9]{1,}$)|[0-9]{2,}\.[0-9]{1,}\.[0-9]{1,}$)", flags=re.MULTILINE)
test_str = ("Target: 4.6.9\n"
"4.6.91\n"
"4.6.19\n"
"4.6.1\n"
"4.6.10\n\n"
"4.63.9\n"
"4.56.9\n"
"4.7.9\n"
"4.5.9\n"
"4.10.9\n"
"4.1.9\n"
"42.6.9\n"
"24.6.9\n"
"5.6.9\n"
"3.6.9\n"
"1.6.9\n"
"10.6.9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")