import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[^>])(Cass\\.\\s+com\\.(?:,\\s+(?:avis|QPC))?,\\s+(\\d{1,2})e?r?(?:\\s| )+(\\w+\\.?)\\s+(\\d{4}),\\s+n(?:°|°|o)s?(?:\\s| )+(\\d{2}-\\d{2})\\.?(\\d{3}))";
final String string = ".Cass. com., 5 janvier 2012, n° 12-45.644";
final String subst = "<renvoi type=\"CASS\" refid=\"$5$6\" jour=\"$2\" mois=\"$3\" annee=\"$4\">$1</renvoi>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}