import Foundation
let pattern = #"(?:^|[^>])(Cass\.\s+com\.(?:,\s+(?:avis|QPC))?,\s+(\d{1,2})e?r?(?:\s| )+(\w+\.?)\s+(\d{4}),\s+n(?:°|°|o)s?(?:\s| )+(\d{2}-\d{2})\.?(\d{3}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #".Cass. com., 5 janvier 2012, n° 12-45.644"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<renvoi type="CASS" refid="$5$6" jour="$2" mois="$3" annee="$4">$1</renvoi>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)